Product Bulletin: BlackBerry® 10

Published: January 31, 2013

Dear Supra eKEY BlackBerry User,
The Supra eKEY app is not compatible with the new BlackBerry 10 operating system. The eKEY application will not run on BlackBerry 10 devices such as the Z10 or Q10.

In our efforts to support our customers, Supra will undertake a comprehensive review of the BlackBerry 10 upon its commercial launch. Among other factors, we consider the adoption rate of Blackberry 10 devices by Supra users and the market in general. If and when Supra decides to support Blackberry 10, we will make an announcement.

Supra eKEY users may consult the Supra Certified Device List for a full list of eKEY-certified devices at www.supraekey.com/documents/current_devices.pdf.

Thank you,
Supra Support Team


Last modified: January 31, 2013 at 2:03 pm | Originally published: January 31, 2013 at 2:03 pm
Printed: September 24, 2020