Sentrilock Card Utility 4.0 Announcement

Published: March 24, 2015

The purpose of this message is to inform you of a required Card Utility upgrade that will need to be completed by agents using older versions of the Card Utility program.  This upgrade will have to be completed by August 31, 2015.
The drivers that the old Card Utility versions use will no longer be supported by the major internet providers after August 31, 2015.  That is why there will be a need for agents to upgrade to the most recent version of the Card Utility.

Starting on March 25, 2015, every time an agent puts their SentriCard in a card reader to renew, it will inform them that they are using an old version of the Card Utility and they will need to upgrade.  It will also provide them with the link to the updated version.  Once they upgrade, the message box will no longer be displayed.  If they are already on the updated version, they will not ever see the message box and continue to update their card as they usually do.

If the agent doesn’t follow the link on the login page, after the card has been successfully renewed, they will get a pop up error message that they are using an old version of the Card Utility, and they will need to upgrade prior to August 31, 2015.  The SentriCard will be renewed, and if they click out of the pop up error message, they will get the message showing that their card was successfully renewed.  Once they upgrade, the message box will no longer be displayed.  If they are already on the updated version, they will not ever see the message box and continue to update their card as they usually do.

If you are using the original card readers from 2003-2005, these card readers do not have drivers available now that can upgrade to the current version of the Card Utility.  The card readers that are affected by this look like this:

Old Card Reader

If you have a card reader that looks like the above, please contact your association to discuss the replacement cost of a more current card reader from SentriLock.  After replacing the card reader, you will need to make sure you upgrade to the newest version of the Card Utility.

Thank you,


Last modified: March 24, 2015 at 5:15 pm | Originally published: March 24, 2015 at 5:15 pm
Printed: September 28, 2020